Ultrastar Deluxe Linux

Leo en TuDeb

Como compilar Ultrastar

Acà esta el excelente tutorial del wiki

Paso 1: Abrir terminal y escribir los siguientes comandos.

sudo apt-get install fp-compiler fp-units-base fp-units-misc
fp-units-fcl  fp-utils libsdl1.2-dev libsdl-image1.2-dev
portaudio19-dev libsqlite3-dev libfreetype6-dev libavcodec-dev
libavformat-dev libswscale-dev

Paso 2:

Respecto a
fp-units-i386
en AMD64 no fue necesario

Tambien instalar las librerias de LUA
sudo apt-get install liblua50-dev liblua50 liblualib50-dev liblualib50 liblua5.1-dev liblua5.1-0
Paso 3:
sudo apt-get install subversion
Paso 4:
svn co https://ultrastardx.svn.sourceforge.net/svnroot/ultrastardx/trunk ultrastardx
al hacer esto debió crearse una carpeta llamada ultrastardx en su carpeta personal para instalar solo debemos entrar en ella desde la terminal.
cd ~/ultrastardx
Paso 5: Ahora ya dentro de la carpeta podremos instalar el juego escribiendo lo siguiente en terminal
./configure
y luego
make
Paso 6:
./game/ultrastardx
con esto cargara el juego

Reblog this post [with Zemanta]

3 pensamientos en “Ultrastar Deluxe Linux”

  1. Hola.
    Instalando el Ultrastar Deluxe en Ubuntu 10.04 me da el siguiente mensaje de error:

    checking for freetype2… yes
    checking for sqlite3… yes
    checking for lua5.1… no
    checking for lua >= 5.1… no
    configure: error:

    Package lua was not found in the pkg-config search path.
    Perhaps you should add the directory containing `lua.pc’
    to the PKG_CONFIG_PATH environment variable
    No package ‘lua’ found

    Alternatively, you may set –with-lua=nocheck and the environment
    variables lua_[…] (see configure –help)
    to appropriate values to avoid the need to call pkg-config.

    See the pkg-config man page for more details.

    Y no me acaba de funcionar. ¿Alguien podría ayudarme?.
    Gracias y un saludo.

    1. Fijate justamente de instalar el Paquete LUA, no recuerdo como se llama pero puedes hacer un
      sudo aptitude search lua
      Seguramente es uno de los lib-lua o lua-dev que falta, con instalar eso seguro ya podrás.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s